Users may be experiencing issues in the Veradigm EHR application.

Incident Report for Veradigm Healthcare Providers

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 15:45 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2026 - 13:16 EDT

Investigating

We are currently addressing an issue that is causing slowness in the Veradigm EHR application for POD A14. We are working to resolve it as quickly as possible.
Posted Jul 21, 2026 - 12:19 EDT
This incident affected: Pod A14 (A14 - EHR).